configuration.nix

This is a working example of my nixos installation, which includes all the apps i use regularly, be aware this will build Thunderbird from source

# Edit this configuration file to define what should be installed on
# your system.  Help is available in the configuration.nix(5) man page
# and in the NixOS manual (accessible by running ‘nixos-help’).

{ config, pkgs, ... }:

{
imports =
  [ # Include the results of the hardware scan.
    ./hardware-configuration.nix
  ];

# Use the GRUB 2 boot loader.
boot.loader.grub.enable = true;
boot.loader.grub.version = 2;
# boot.loader.grub.efiSupport = true;
# boot.loader.grub.efiInstallAsRemovable = true;
# boot.loader.efi.efiSysMountPoint = "/boot/efi";
# Define on which hard drive you want to install Grub.
boot.loader.grub.device = "/dev/sda"; # or "nodev" for efi only
boot.loader.grub.useOSProber = true;

networking.hostName = "nixos"; # Define your hostname.
networking.wireless.enable = true;  # Enables wireless support via wpa_supplicant.

# Set your time zone.
time.timeZone = "Europe/London";

# The global useDHCP flag is deprecated, therefore explicitly set to false here.
# Per-interface useDHCP will be mandatory in the future, so this generated config
# replicates the default behaviour.
networking.useDHCP = false;
networking.interfaces.eno0.useDHCP = true;
networking.interfaces.wlp2s0.useDHCP = true;

# Configure network proxy if necessary
# networking.proxy.default = "http://user:password@proxy:port/";
# networking.proxy.noProxy = "127.0.0.1,localhost,internal.domain";

# Select internationalisation properties.
 i18n.defaultLocale = "en_GB.UTF-8";
 console = {
   font = "Lat2-Terminus16";
   keyMap = "uk";
 };

# Enable the Plasma 5 Desktop Environment.
services.xserver.enable = true;
services.xserver.displayManager.sddm.enable = true;
services.xserver.desktopManager.plasma5.enable = true;
services.xserver.videoDrivers = [ "modesetting" ];
services.xserver.useGlamor = true;


# Configure keymap in X11
services.xserver.layout = "gb";
# services.xserver.xkbOptions = "eurosign:e";

# Enable CUPS to print documents.
services.printing.enable = true;
services.printing.drivers = [ pkgs.hplip ];
services.avahi.enable = true;
# Important to resolve .local domains of printers, otherwise you get an error
# like  "Impossible to connect to XXX.local: Name or service not known"
services.avahi.nssmdns = true;

# Enable sound.
sound.enable = true;
hardware.pulseaudio.enable = true;

# Enable touchpad support (enabled default in most desktopManager).
services.xserver.libinput.enable = true;

# Define a user account. Don't forget to set a password with ‘passwd’.
users.users.username = {
   isNormalUser = true;
   extraGroups = [ "wheel" "networkmanager" ]; # Enable ‘sudo’ for the user.
 };

# List packages installed in system profile. To search, run:
# $ nix search wget
environment.systemPackages = with pkgs; [
   firefox
   qutebrowser
   thunderbird
   keepassxc
   krita
   kde-gtk-config
   kdeplasma-addons
   plasma-browser-integration
   ark
   pkgs.kdeApplications.dolphin-plugins
   pkgs.kdeApplications.kipi-plugins
   pkgs.kdeApplications.kio-extras
   sddm-kcm
   gwenview
   kolourpaint
   kcolorchooser
   dragon
   okular
   skanlite
   kcalc
   krename
   gsmartcontrol
   imagemagick
   gimp
   kdeconnect
   tlp
   rsync
   wget
   syncthing
   libreoffice
   w3m
   sshfs
   mc
   aerc
   htop
 ];

# Some programs need SUID wrappers, can be configured further or are
# started in user sessions.
# programs.mtr.enable = true;
# programs.gnupg.agent = {
#   enable = true;
#   enableSSHSupport = true;
# };

# List services that you want to enable:

# Enable the OpenSSH daemon.
services.openssh.enable = false;

# Open ports in the firewall.
networking.firewall.allowedTCPPorts = [22000];
networking.firewall.allowedTCPPortRanges = [ { from = 1714; to = 1764; } ];  
networking.firewall.allowedUDPPorts = [21027 ];
networking.firewall.allowedUDPPortRanges = [ { from = 1714; to = 1764; } ];
# Or disable the firewall altogether.
# networking.firewall.enable = false;

services = {
  syncthing = {
      enable = true;
      user = "username";
      dataDir = "/home/username/Syncthing-Folders/";
      configDir = "/home/username/Syncthing-Folders/.config/syncthing";
  		};
};

#systemd.services.systemd-udev-settle.enable = false;
#systemd.services.NetworkManager-wait-online.enable = false;

# This value determines the NixOS release from which the default
# settings for stateful data, like file locations and database versions
# on your system were taken. It‘s perfectly fine and recommended to leave
# this value at the release version of the first install of this system.
# Before changing this value read the documentation for this option
# (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
system.stateVersion = "20.09"; # Did you read the comment?

}